【Drupal官方团队消息】Drupal 7,8和9

我们刚刚发布了Drupal 8.6.0。我们有六个小版本,现在是时候谈论Drupal 8的长期未来(因此Drupal 7和Drupal 9)。我已经写了过去何时发布Drupal 9,但这一次,我已准备好提供进一步的细节。

本博客中概述的计划已与Drupal 7核心提交者,Drupal 8核心提交者和Drupal安全团队进行了讨论。虽然我们对此计划感到满意,但我们无法计划每一个可能性,我们可能会继续进行调整。

Drupal 8将在2021年11月结束

Drupal 8的创新模型依赖于在次要版本中引入新功能,同时保持向后兼容性。这种方法运作良好,有些人建议我们永远制作小版本,并且根本不会发布Drupal 9。

然而,这种方法是不可行的。我们需要定期删除已弃用的功能以保持Drupal的现代化,可维护性和高性能,并且我们需要保持安全,受支持的Drupal 8的第三方依赖项版本。正如Nathaniel Catchpole在他的文章“Drupal 9的漫长之路”中所解释的那样,我们使用Symfony,Twig和Guzzle等各种第三方库意味着我们需要与他们的发布时间表保持同步。

我们对Drupal 8的最大依赖是Symfony 3,根据Symfony的路线图,Symfony 3在2021年11月的生命终止日期。这意味着在2021年11月之后,Symfony 3中的安全漏洞将无法修复。为了确保您的Drupal站点安全,Drupal必须在Symfony 3停止使用之前采用Symfony 4或Symfony 5。一个主要的Symfony升级将要求我们发布Drupal 9(我们不想分叉Symfony 3并且必须向后移植Symfony 4或Symfony 5错误修复)。这意味着我们必须在2021年11月之前终止Drupal 8。

Drupal 8将在2021年11月结束

Drupal 9将于2020年发布,它将是一个简单的升级

如果Drupal 8将于2021年11月终止,我们必须在此之前发布Drupal 9。从2021年11月开始倒退,我们想给网站所有者一年的时间从​​Drupal 8升级到Drupal 9。

如果2020年11月是最新版本,我们可以发布Drupal 9,我们最早可以发布Drupal 9的最新版本是什么?

我们当然不能在下周甚至下个月发布Drupal 9。准备Drupal 9需要做很多工作:我们需要采用Symfony 4和/或Symfony 5,我们需要删除已弃用的代码,我们需要允许模块和主题声明与多个主要版本的兼容性,甚至更多。Drupal 8核心提交者认为我们需要一年多的时间来准备Drupal 9

因此,我们目前的计划是在2020年发布Drupal 9.由于我们仍需要弄清楚重要的细节,我们现在不能更具体。

Drupal 9将于2020年发布

如果我们在2020年发布Drupal 9,这意味着我们肯定会有Drupal 8.7和8.8版本。

等等,我只有一年的时间从​​Drupal 8迁移到9?

是的,但幸运的是从Drupal 8转到9将比以前的主要版本升级容易得多。Drupal 9的第一个版本与Drupal 8的最后一个次要版本非常相似,因为Drupal 9.0.0版本的主要目标是删除已弃用的代码并更新第三方依赖项。通过使您的Drupal 8站点保持最新,您应该为Drupal 9做好充分准备。

贡献的模块怎么样?贡献模块的兼容性在历史上是升级的最大阻碍之一,因此我们还可以使贡献的模块同时与Drupal 8和Drupal 9兼容。只要贡献的模块不使用已弃用的API,它们应该与Drupal 9一起使用,同时仍然与Drupal 8兼容。

Drupal 7将一直支持到2021年11月

从历史上看,我们的政策一直只支持Drupal的两个主要版本; 当Drupal 9被释放时,Drupal 7通常会达到使用寿命。由于到2020年大量网站可能仍在使用Drupal 7,我们决定将Drupal 7的支持延长到2021年11月.Dupupal 7将在三年内获得社区支持。

Drupal 7将一直支持到2021年11月

我们将推出Drupal 7商业长期支持计划

过去,商业供应商已经扩展了Drupal的安全支持。2015年,Drupal 6商业长期支持计划启动并持续至今。我们计划为Drupal 7提供类似的付费程序,以在2021年11月之后提供支持.Drupal Security Team将在2019年中期之前公布Drupal 7商业LTS计划信息。就像Drupal 6 LTS程序一样,将有供应商的应用程序。

我们将更新Drupal 7以支持更新版本的PHP

PHP团队将于2018年12月31日(3个月)停止支持PHP 5.x,2018年12月3日(2个月)支持PHP 7.0,2019年12月1日支持PHP 7.1(1年零3个月) PHP 7.2于2020年11月30日(2年零2个月)。

Drupal将放弃对不受支持的PHP版本的官方支持,Drupal 7站点所有者可能必须升级他们的PHP版本。细节将在稍后提供。

我们计划更新Drupal 7以支持符合其支持计划的更新版本的PHP。Drupal 7并不完全支持PHP 7.2,因为自PHP 7.1以来存在一些向后不兼容的更改。我们将发布支持PHP 7.2的Drupal 7版本。即使不是,也必须更新贡献的模块和自定义模块。

结论

如果您仍在使用Drupal 7并且想知道该怎么做,那么您目前有两个选择:

  1. 继续使用Drupal 7同时更新您的PHP版本。如果您在2021年之前继续使用Drupal 7,您可以聘请供应商获得长期支持合同,也可以迁移到Drupal 9。
  2. 到2020年迁移到Drupal 8,以便在发布时更容易更新到Drupal 9。

此博客文章中的公告使选项(1)更加可行和/或有希望帮助您更好地评估选项(2)。

如果你在Drupal 8上,你只需要保持你的Drupal 8站点是最新的,你就可以为Drupal 9做好准备了。

我们计划在2019年4月之前提供更多细节(DrupalCon Seattle)。

感谢Drupal 7核心提交者,Drupal 8核心提交者和Drupal安全团队对本博文的贡献。

暂无评论

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注